Контрольная работа : Анализ области определения функции 


Полнотекстовый поиск по базе:

Главная >> Контрольная работа >> Информатика, программирование


Анализ области определения функции




План

Постановка задачи

Анализ области определения функции

Рабочий лист Excel в режиме отображения значений

Рабочий лист Excel в режиме отображения формул

Постановка задачи

Для функции построить таблицу значений этой функции (протабулировать функцию) при значениях аргумента, изменяющихся на отрезке (a,b) с шагом h = (b-a)/h (n=20), найти наибольшее и наименьшее значение функции на этом отрезке и построить график.

Анализ области определения функции

При х = 0 знаменатель дроби тоже равен нулю, значит при х = 0, функция не существует. Таким образом, выражение для табулирования данной функции имеет вид:

=ЕСЛИ(C12=0;"Не сущ.";EXP(1-C12^2)/LN(1+C12^2))

Рабочий лист Excel в режиме отображения значений

Контрольная работа №1

Табулирование функции одной переменной

Исходные данные

Начальная граница отрезка a =

-1

Конечная граница отрезка b =

1

Количество интервалов n =

20

Шаг табулирования h =

0,1

Результаты вычислений

№ п/п

x

y

Экстремумы

1

-1,00

1,44

<=мин.

2

-0,90

2,04

3

-0,80

2,90

4

-0,70

4,18

5

-0,60

6,17

6

-0,50

9,49

7

-0,40

15,61

8

-0,30

28,83

9

-0,20

66,59

10

-0,10

270,47

<=макс.

11

0,00

Не сущ.

12

0,10

270,47

<=макс.

13

0,20

66,59

14

0,30

28,83

15

0,40

15,61

16

0,50

9,49

17

0,60

6,17

18

0,70

4,18

19

0,80

2,90

20

0,90

2,04

21

1,00

1,44

<=мин.

Рабочий лист Excel в режиме отображения формул

Контрольная работа №1

Табулирование функции одной переменной

Исходные данные

Начальная граница отрезка a =

-1

Конечная граница отрезка b =

1

Количество интервалов n =

20

Шаг табулирования h =

=(E6-E5)/E7

Результаты вычислений

№ п/п

x

y

Экстремумы

=СТРОКА()-11

=$E$5+(B12-1)*$E$8

=ЕСЛИ(C12=0;"Не сущ.";EXP(1-C12^2)/LN(1+C12^2))

=ЕСЛИ(D12=МАКС($D$12:$D$32);"<=макс.";

ЕСЛИ(D12=МИН($D$12:$D$32);"<=мин.";""))

=СТРОКА()-11

=$E$5+(B13-1)*$E$8

=ЕСЛИ(C13=0;"Не сущ.";EXP(1-C13^2)/LN(1+C13^2))

=ЕСЛИ(D13=МАКС($D$12:$D$32);"<=макс.";

ЕСЛИ(D13=МИН($D$12:$D$32);"<=мин.";""))

=СТРОКА()-11

=$E$5+(B14-1)*$E$8

=ЕСЛИ(C14=0;"Не сущ.";EXP(1-C14^2)/LN(1+C14^2))

=ЕСЛИ(D14=МАКС($D$12:$D$32);"<=макс.";

ЕСЛИ(D14=МИН($D$12:$D$32);"<=мин.";""))

=СТРОКА()-11

=$E$5+(B15-1)*$E$8

=ЕСЛИ(C15=0;"Не сущ.";EXP(1-C15^2)/LN(1+C15^2))

=ЕСЛИ(D15=МАКС($D$12:$D$32);"<=макс.";

ЕСЛИ(D15=МИН($D$12:$D$32);"<=мин.";""))

=СТРОКА()-11

=$E$5+(B16-1)*$E$8

=ЕСЛИ(C16=0;"Не сущ.";EXP(1-C16^2)/LN(1+C16^2))

=ЕСЛИ(D16=МАКС($D$12:$D$32);"<=макс.";

ЕСЛИ(D16=МИН($D$12:$D$32);"<=мин.";""))

=СТРОКА()-11

=$E$5+(B17-1)*$E$8

=ЕСЛИ(C17=0;"Не сущ.";EXP(1-C17^2)/LN(1+C17^2))

=ЕСЛИ(D17=МАКС($D$12:$D$32);"<=макс.";

ЕСЛИ(D17=МИН($D$12:$D$32);"<=мин.";""))

=СТРОКА()-11

=$E$5+(B18-1)*$E$8

=ЕСЛИ(C18=0;"Не сущ.";EXP(1-C18^2)/LN(1+C18^2))

=ЕСЛИ(D18=МАКС($D$12:$D$32);"<=макс.";

ЕСЛИ(D18=МИН($D$12:$D$32);"<=мин.";""))

=СТРОКА()-11

=$E$5+(B19-1)*$E$8

=ЕСЛИ(C19=0;"Не сущ.";EXP(1-C19^2)/LN(1+C19^2))

=ЕСЛИ(D19=МАКС($D$12:$D$32);"<=макс.";

ЕСЛИ(D19=МИН($D$12:$D$32);"<=мин.";""))

=СТРОКА()-11

=$E$5+(B20-1)*$E$8

=ЕСЛИ(C20=0;"Не сущ.";EXP(1-C20^2)/LN(1+C20^2))

=ЕСЛИ(D20=МАКС($D$12:$D$32);"<=макс.";

ЕСЛИ(D20=МИН($D$12:$D$32);"<=мин.";""))

=СТРОКА()-11

=$E$5+(B21-1)*$E$8

=ЕСЛИ(C21=0;"Не сущ.";EXP(1-C21^2)/LN(1+C21^2))

=ЕСЛИ(D21=МАКС($D$12:$D$32);"<=макс.";

ЕСЛИ(D21=МИН($D$12:$D$32);"<=мин.";""))

=СТРОКА()-11

=$E$5+(B22-1)*$E$8

=ЕСЛИ(C22=0;"Не сущ.";EXP(1-C22^2)/LN(1+C22^2))

=ЕСЛИ(D22=МАКС($D$12:$D$32);"<=макс.";

ЕСЛИ(D22=МИН($D$12:$D$32);"<=мин.";""))

=СТРОКА()-11

=$E$5+(B23-1)*$E$8

=ЕСЛИ(C23=0;"Не сущ.";EXP(1-C23^2)/LN(1+C23^2))

=ЕСЛИ(D23=МАКС($D$12:$D$32);"<=макс.";

ЕСЛИ(D23=МИН($D$12:$D$32);"<=мин.";""))

=СТРОКА()-11

=$E$5+(B24-1)*$E$8

=ЕСЛИ(C24=0;"Не сущ.";EXP(1-C24^2)/LN(1+C24^2))

=ЕСЛИ(D24=МАКС($D$12:$D$32);"<=макс.";

ЕСЛИ(D24=МИН($D$12:$D$32);"<=мин.";""))

=СТРОКА()-11

=$E$5+(B25-1)*$E$8

=ЕСЛИ(C25=0;"Не сущ.";EXP(1-C25^2)/LN(1+C25^2))

=ЕСЛИ(D25=МАКС($D$12:$D$32);"<=макс.";

ЕСЛИ(D25=МИН($D$12:$D$32);"<=мин.";""))

=СТРОКА()-11

=$E$5+(B26-1)*$E$8

=ЕСЛИ(C26=0;"Не сущ.";EXP(1-C26^2)/LN(1+C26^2))

=ЕСЛИ(D26=МАКС($D$12:$D$32);"<=макс.";

ЕСЛИ(D26=МИН($D$12:$D$32);"<=мин.";""))

=СТРОКА()-11

=$E$5+(B27-1)*$E$8

=ЕСЛИ(C27=0;"Не сущ.";EXP(1-C27^2)/LN(1+C27^2))

=ЕСЛИ(D27=МАКС($D$12:$D$32);"<=макс.";

ЕСЛИ(D27=МИН($D$12:$D$32);"<=мин.";""))

=СТРОКА()-11

=$E$5+(B28-1)*$E$8

=ЕСЛИ(C28=0;"Не сущ.";EXP(1-C28^2)/LN(1+C28^2))

=ЕСЛИ(D28=МАКС($D$12:$D$32);"<=макс.";

ЕСЛИ(D28=МИН($D$12:$D$32);"<=мин.";""))

=СТРОКА()-11

=$E$5+(B29-1)*$E$8

=ЕСЛИ(C29=0;"Не сущ.";EXP(1-C29^2)/LN(1+C29^2))

=ЕСЛИ(D29=МАКС($D$12:$D$32);"<=макс.";

ЕСЛИ(D29=МИН($D$12:$D$32);"<=мин.";""))

=СТРОКА()-11

=$E$5+(B30-1)*$E$8

=ЕСЛИ(C30=0;"Не сущ.";EXP(1-C30^2)/LN(1+C30^2))

=ЕСЛИ(D30=МАКС($D$12:$D$32);"<=макс.";

ЕСЛИ(D30=МИН($D$12:$D$32);"<=мин.";""))

=СТРОКА()-11

=$E$5+(B31-1)*$E$8

=ЕСЛИ(C31=0;"Не сущ.";EXP(1-C31^2)/LN(1+C31^2))

=ЕСЛИ(D31=МАКС($D$12:$D$32);"<=макс.";

ЕСЛИ(D31=МИН($D$12:$D$32);"<=мин.";""))

=СТРОКА()-11

=$E$5+(B32-1)*$E$8

=ЕСЛИ(C32=0;"Не сущ.";EXP(1-C32^2)/LN(1+C32^2))

=ЕСЛИ(D32=МАКС($D$12:$D$32);"<=макс.";

ЕСЛИ(D32=МИН($D$12:$D$32);"<=мин.";""))

Похожие работы: